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1. First Use
1.1 System Requirements
Our recommendations and minimum system requirements are meant to provide general guidelines for running GMG ColorPlugin. We recommend systems that meet or exceed the following requirements.
Processor: CPU with 2 GHz (or higher)
Memory: 4 GB RAM, 250 GB hard disk drive
Network:
10/100 Mbps with internet connection
Connection to "lcs.webservice.gmgcolor.com"
Connection to "pspluginprofiles-eu-west-1.s3.amazonaws.com"
Operating system:
MAC OS X 10.12 – MAC OS X 10.15
Windows 10 (64-bit)
Software requirements:
Photoshop CC2015 – CC2020
For using custom profiles: GMG ProfileEditor integrated in GMG ColorServer version 4.10

1.2 Installation

1. Double-click the installer file and follow the instructions of
the installer.

1. Double-click the installer file and follow the instructions of
the installer.

2. When the installation is complete, click the Close button to
exit the installer.

2. When the installation is complete, click the Finish button to
exit the installer.
(If you have Adobe CS6, a 32-bit and a 64-bit version of the
plugin will be installed. If you use Adobe Creative Cloud
2014, only the 64-bit version of the plugin will be
installed.)

1.3 Starting and Licensing the Plugin
After the plugin is installed, you need to generate and activate a license. Licenses are generated and activated directly in the software.
Available licenses
GMG ColorPlugin Standard
Color conversion with GMG supplied profiles from one industry standard into another.
GMG ColorPlugin Pro
Color conversion with GMG supplied profiles, custom and GMG InkOptimizer profiles.
GMG ColorPlugin Packaging
Color conversion as in "Pro" plus packaging tools.
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How to start and license GMG ColorPlugin
1. Start Adobe Photoshop.
GMG ColorPlugin will ask you to fill in a form to request a free trial version.
2. Fill in the form and click Start Trial.
The trial will start immediately, i. e. you can start to use the plugin right away. (You will not receive
an e-mail notification.) The filled in form will be sent to GMG. (If you are not able to connect the
computer to the internet, you will be asked to send a generated license request file to GMG via email. In this case, you might wait for the trial license for one or two working days.)
3. Click Close to close the License Overview and you can directly start working with GMG ColorPlugin.
4. If you want to check the license status later:
Click File > Automate > GMG Preferences.
—OR—
Add a check mark to Window > Extensions > GMG ColorPlugin to show the plugin and click the
Preferences button in the plugin panel.

Fig. 1 License ready.
License information is updated each time you restart the main application. For example, if you decide to
buy the product, the expiry date will be automatically updated. If you need to update the license without
restarting, you can click the Get License button. If it is not possible for you to establish an internet connection, you can also switch to Offline mode.

1.4 Licensing the Plugin without Internet Connection
Tip The easiest and fastest way to request or update your license will be via an internet connection. Even
if the computer running the main application is generally not connected to the internet, it is preferable
that you establish an internet connection for the short time of license transfer (couple of seconds). You will
not need an active internet connection after the license transfer. It is sufficient to allow an internet connection to "lcs.webservice.gmgcolor.com". However, if you are not able to establish an internet connection, it is possible to request a license in offline mode.

4 / 26

GMG ColorPlugin Quick Start Guide (EN)

How to update the license of GMG ColorPlugin in offline mode
This procedure is required, for example, if you are currently using a trial license and have purchased the
product or if you have upgraded your license. Your license request will be processed manually at GMG, so
it can take one or two working days until you will get the license.
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1. Start Adobe Photoshop.
When starting GMG ColorPlugin for the first time, a message box will show up with a notification if
no license has been found. Confirm the notification to display the License Overview.
2. If you have not been prompted by a message box, you can click File > Automate > GMG Preferences.
—OR—
Add a check mark to Window > Extensions > GMG ColorPlugin to show the plugin and click the
Preferences button in the plugin panel.

3. In the License Overview window, click the Request License button.

A license request file (GMGLicenceRequest0_xx.lrq) will be generated and saved to your desktop.
The file is bound to the hardware configuration of a specific computer and thus needs to be created
separately for each device.
4. Transfer the license request file to a computer with internet connection and send it to the following email address:
order@gmgcolor.com.
5. You will receive a license file with the file extension *.lic in return after one or two working days.
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6. Transfer the file to the computer running the application for which you requested the license and
activate it by clicking the Activate License button and loading the file. If you requested multiple
licenses for different computers, make sure to load the file that was created for this computer.
The loaded license is now activated and listed in the License Overview.
7. Click Close to close the License Overview and start working with GMG ColorPlugin.
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2. Getting Started
2.1 What's New?
This chapter summarizes all major changes that have been applied to the program since the latest release.
It is recommended to take the time to read the information provided in this chapter carefully, so that you
can take full advantage of all new software features. Please follow the links for more information.
What's New in Version 1.3?
Note GMG ColorPlugin 1.3 uses a revised licensing procedure, which requires an update of existing
licenses. This update should be handled automatically, without interrupting your work.
Note End of life support of Adobe Photoshop CS5.
New Feature

See Also

"ChannelExtender: Separate RGB to
Using the new ChannelExtender functionality, you can use devicelink GMG OpenColor profiles to separate the whole design from RGB to your custom GMG OpenColor project directly Expanded Color Gamut (ECG)" on
in Adobe Photoshop. GMG OpenColor calculates the required separation profiles in advance page 14
and provides them to the plugin on request via a direct connection. (Requires a GMG OpenColor license and version 2.1.4 or higher.)
Expanded Color Gamut (ECG) printing, also referred to as Fixed Color Palette printing, uses a
standardized ink set enhancing the color space to reproduce any color used in the design. In
the plugin, up to three additional inks can be used. The inks need to be between the CMYK
process colors, i. e. Red or Orange, Green, and/or Blue or Violet.
This method allows for a virtually unlimited number of colors in the design and also for nesting print jobs with different color channels, without changing the ink configuration of the printing machine.
Using ECG, design can be more eye-catching, resulting in highly saturated colors. The print result is closer to the original RGB design. As the ink setup is standardized, printers are saving on
make-ready and ink costs.
Soft proofing: The new Work Preview functionality allows editing of the original document in
RGB while providing a color accurate simulation of the print result. The Work Preview automatically uses the correct GMG OpenColor profile for the Adobe Photoshop Proof Colors
functionality.
Extended MinDot features:

"MinDot Adjust and Preview: Setting
the Minimum Dot" on page 19

Spot color support, i. e. MinDot Adjust and MinDot Preview do now support CMYK +
spot colors (any number).
MinDot Preview does not add an entry to the Adobe Photoshop History anymore, as
the preview does not alter the document.
Set with Curve: Transfers all color values below the defined threshold to the printable
tone value range while keeping details in the gradients. To avoid a visible edge and to
keep details, a curve is applied to the clipped values and to the color values slightly
above the threshold.
Improved soft proofing with OpenColor Preview: Supports now more than 8 profile channels.
Simplified licensing procedure. If the computer on which the plugin is installed has an active "Starting and Licensing the Plugin" on
internet connection, purchased licenses will be automatically updated. In case a problem with page 3
a valid license occurs, the license will be automatically restored 24/7.
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New Feature

See Also

Support of new characterizations FOGRA53 and FOGRA54:
FOGRA53 is a CMYK based and media neutral color exchange space that primarily serves
color communication throughout the print production, including copy preparation, job
assembly, proofing, and process color printing.
FOGRA54 characterizes a web offset heatset printing process using PS6 (super calendered
uncoated SC-B) medium.
Support of Adobe Photoshop CC2018

2.2 Welcome
GMG ColorPlugin is a cross-platform plugin for high quality GMG color conversions within Adobe Photoshop. You are not only able to convert entire documents, but single or multiple layers and selections as
well! By applying GMG DeviceLink profiles instead of ICC profiles, a number of benefits are gained, leading to improved productivity.
The GMG ColorPlugin allows the removal and compensation of single channels, which saves valuable
time in retouching departments. After the color compensation, the visual impression of the image is completely preserved.
CMYK channels can also be replaced by spot color channels via a direct connection to GMG OpenColor,
including a color-accurate preview that shows how the inks will interact with each other on press.

Fig. 2 GMG ColorPlugin integrated into Adobe Photoshop.
Even more performance for the pre-press stage
l

Separations from RGB to Multicolor up to 7C

l

ColorBoost for saturated and vivid images

l

MinDot Adjust and MinDot Preview also for spot colors
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Save time and raise quality
l

Flexible tools for automating the most often used process steps

l

Processing of complete subjects, individual selections or layers

l

Color-accurate conversions

2.3 Which Color Conversions Are Possible?
The following conversions and separations can be applied to whole files, single or multiple layers and
even masked ares.
RGB-to-CMYK: The RGB-to-CMYK conversion uses a special gamut mapping to minimize visual
changes when reducing the larger RGB color space to the smaller CMYK color space.
RGB-to-ECG (ChannelExtender functionality): Separate RGB images to your custom ink setup to
extend your color space. Up to 7 output channels are supported. By using a devicelink color space
conversion and premium GMG gamut mapping algorithms, you will be able to get brilliant colorful
printings.
CMYK-to-RGB: CMYK data is converted to RGB from a print standard such as ISO or GRACoL to a
print process neutral AdobeRGB color space (or vice versa). CMYK-to-RGB conversion is particularly
useful for normalizing CMYK images in multiple color spaces to a common color space.
CMYK-to-CMYK: CMYK data is converted from a print standard such as PSR, ISO, GRACoL, and
3DAP to another (CMYK) print standard.
Using four-dimensional DeviceLink profiles, the source and target values are computed directly in
CMYK—without using CIELab as an intermediate color space. The black channel separation from the
original data is preserved when transforming into the target CMYK color space, preserving the visual
impression of the document.
CMYK-to-ChannelChanger: CMYK data is converted to a GMG OpenColor ChannelChanger profile.
This allows you to change the separation channels of a CMYK image to any four channels of your target color space. This is especially useful for individual separations of marquee selections or layers.
GMG OpenColor technology ensures color consistency during the conversion.
Reseparation: CMYK data is reseparated to harmonize different UCR/GCR settings for a consistent
color channel separation, delivering a highly stable and reproducible print result.
InkOptimizer: CMYK data is reseparated to optimize the color composition (gray balance) for a specific printing condition and for a specific Total Area Coverage (TAC). InkOptimizer profiles reduce
the quantity of CMY inks while increasing the proportion of black ink without changing the visual
color impression of the print.
(Requires a ColorPlugin Pro license.)
Custom: RGB or CMYK data is converted according to your own profiles created in GMG ProfileEditor
or GMG OpenColor.
(Requires a ColorPlugin Pro or Packaging license.)
Note Adjustment layers are maintained, except in CMYK-to-RGB conversions (which remove all adjustment layers).
Conversion Options
Option

Description

Replace Assigned
ICC Profile

Replaces the assigned ICC profile (output intent) of the open file after the color conversion. The replacement is prerequisite for a correct softproof view of the conversion.
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Process Hidden Layers

You can choose whether you also want hidden or locked layers to be converted or not.

Unlock and Process
Locked Layers
Apply to Proof Colors

Applies the selected Destination Space in Photoshop's soft proofing feature Proof Colors.
Note: If you undo a conversion, the soft proofing settings will not be undone accordingly due to a technical limitation of Photoshop.

2.4 Preferences
Click File > Automate > GMG Preferences or click the gearwheel button in the GMG ColorPlugin
extension.

Fig. 3 Preferences.
You can download all standard GMG profiles from the cloud (1). During each start of a color conversion,
the plugin checks for new profiles online. To avoid a timeout on an offline computer, deselect the check
for new profiles.
A direct connection to a GMG OpenColor instance is required to use some features. After you have
entered an IP address and port, you can check your connection (2).

2.5 GMG ColorPlugin Panel
If you are using Photoshop CC, you can also show the plugin as a panel on the workspace.
To show the panel, click Window > Extensions > GMG ColorPlugin.
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Fig. 4 Screenshot of the GMG ColorPlugin panel.
The GMG ColorPlugin panel gives you direct access to all its features (1) and preferences (2).
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3. Features
3.1 ChannelChanger: Reseparating Image Channels according to the Output Colors
(missing or bad snippet)
You can reseparate CMYK data using a GMG OpenColor ChannelChanger profile. This means you can
change the input channels of an image area to any four channels available in your target color space.
In GMG OpenColor, you will need a project characterizing the output colors / target color space. You will
then need to publish the separation profiles to make the project available to the GMG ColorPlugin. You
may, but you do not need to, precalculate ChannelChanger profiles in GMG OpenColor. You also do not
need to export the profiles. GMG ColorPlugin connects to GMG OpenColor and requests the needed profiles on-the-fly.
In the GMG ColorPlugin, you can then divide the image in sections that have a maximum of four output
channels and then select the desired output channels.

Fig. 5 ChannelChanger.
The Output Channels list shows all output channels available in the selected GMG OpenColor project,
regardless whether separation profiles have already been precalculated for the channels or not. In the
example, Black has been replaced by Pantone 469 C.
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How to use ChannelChanger
Note You will need a GMG OpenColor project with a published ChannelChanger separation profile.
Tip Use the OpenColor Preview to get a color correct soft-proof.
1. Open a CMYK image in Adobe Photoshop.
2. Select an area or layer that you want to reseparate. The selection must not require more than four output channels.
3. Click File > Automate > GMG ChannelChanger or select GMG ChannelChanger in the plugin panel.
4. Select the GMG OpenColor project defining the target color space.
5. Select maximal four output channels for your separation.
6. In case of four output channels, define the key color of your separation.
7. In case of four output channels, set the level of Gray Component Replacement (GCR). This way you
can reduce the amount of CMY in gray areas while increasing the amount of Black.
8. If you want to process hidden or locked layers, set the conversion options accordingly.
9. Confirm your settings with the OK button.
GMG ColorPlugin will request a ChannelChanger profile matching the selected output channels and
settings from GMG OpenColor. If no matching profile exists, GMG OpenColor will calculate it and
then send it to the plugin. As soon as the profile is available, the plugin will start the conversion.
Requested profiles will also be shown in GMG OpenColor and might be reused later.

3.2 ChannelExtender: Separate RGB to Expanded Color Gamut (ECG)
Expanded Color Gamut (ECG) printing, also referred to as Fixed Color Palette printing, uses a standardized ink set enhancing the color
space to reproduce any color used in the design. In the plugin, up to three additional inks can be used. The inks need to be between
the CMYK process colors, i. e. Red or Orange, Green, and/or Blue or Violet.
This method allows for a virtually unlimited number of colors in the design and also for nesting print jobs with different color channels, without changing the ink configuration of the printing machine.
Using ECG, design can be more eye-catching, resulting in highly saturated colors. The print result is closer to the original RGB design.
As the ink setup is standardized, printers are saving on make-ready and ink costs.

As the profile calculation takes a considerable amount of time, GMG OpenColor calculates the required
separation profiles in advance and provides them to the plugin on request via a direct connection.
How to use ChannelExtender
Note You will need a GMG OpenColor project with precalculated and published ChannelExtender separation profiles. Make sure the Input Color Space of the separation profile matches the document color
space (not the working space).
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1. Open an RGB image in Adobe Photoshop.
2. Click File > Automate > ChannelExtender or click ChannelExtender in the plugin panel.
3. Select the GMG OpenColor project defining the target color space.
A list with Output Inks available in the project will be shown. If no channels are shown or channels
are missing, please check that the Source Color Space is matching and that the required profile variants have been calculated.
4. Select the additional inks you want to use. (You cannot deselect CMYK.)
5. Set the Color Boost level, which controls the saturation of the image.
6. Click Work Preview if you want to edit the document further in Photoshop or click OK if you want to
convert the document right away.
The first time you are using a ChannelExtender profile, Adobe Photoshop needs to initialize internal
parameters. As a side effect, the following dialog box will be shown. Just ignore it and click OK or
Cancel. The settings in the dialog box will be ignored. The plugin will always use the correct profile,
no matter of the settings.

Fig. 6 ChannelExtender.
The example shows an ISO Coated target color space extended by Orange, Green, and Blue inks.
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Fig. 7 ChannelExtender example data.
On the left, you can see the original RGB image. On the right, the color boosted 7c image.
Soft proofing
The Work Preview functionality allows editing of the original document in RGB while providing a color
accurate simulation of the print result. The Work Preview automatically uses the correct GMG OpenColor
profile for the Adobe Photoshop Proof Colors functionality.

3.3 ChannelRemover: Removing Channels from Areas without Changing the Color
The ChannelRemover tool allows a quick and accurate removal of complete color channels from layers or
masks, particularly useful in packaging production, e.g. for removing cyan from brown areas.
How to remove an image channel
1. Open a CMYK image in Adobe Photoshop.
2. Select an area or layer that you to clean up from a certain color.

3. Click File > Automate > GMG ChannelRemover or select GMG ChannelRemover in the plugin
panel.
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4. Deselect the channel you want to remove and click OK.
In our example, we deselected Cyan to remove it from the selected area.

17 / 26

3. Features
5. Check the result, for example by viewing the removed channel.

The removal will automatically be compensated for so that the color stays the same (unless, of course
you remove a channel from an image object that is essential such as magenta for a red object).

3.4 ColorConversion: Converting the Image to a New Printing Condition
Using ColorConversion, you can convert the entire image to a new printing condition. For example, if the
original design had been created for ISO Coated v2, but it was later decided to use the process standard
PSO Coated v3.
You can either preserve the existing separations, for example, if it was already optimized before, or reseparate the image. Also, you can use GMG InkOptimizer to minimize the ink usage.
Source Space
By selecting the source space, you define the input color space of the document you want to convert. If
the document has an ICC profile assigned to it, it will automatically be preselected as Source Space.
Destination Space
The destination space is the target color space you want to convert your image to. All GMG conversion
and separation profiles are certified according to official print standards.
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Load Custom Profile
With a GMG ColorPlugin Pro or Packaging license, you can also apply your own color conversion or separation profiles created in GMG ProfileEditor or GMG OpenColor. This option has been added to browse
for a specific profile for one-time use. Alternatively, you can store several profiles in the profile library for
quicker access.
How to use ColorConversion
1. Open a CMYK or RGB image in Adobe Photoshop.
2. Click File > Automate > ColorConversion or click ColorConversion in the plugin panel.
3. Select a Source Space and a Destination Space and click OK to convert your data.

Fig. 8 ColorConversion.
In the example, the image will be converted from ISO Coated v2 to PSO Coated v3, preserving the separations and replacing the assigned ICC profile accordingly.

3.5 MinDot Adjust and Preview: Setting the Minimum Dot
In Flexo printing processes, there is a physical minimum dot that can be held on the printing plate as well
as a production minimum dot. In combination with process related dot gain and ink drying, this can result
in a noticeable edge.
The MinDot Preview highlights image areas that might be affected by this problem in the color of the
respective separation (C, M, Y, K, or spot color) so they are easy to locate and fix. Unprinted areas, which
cannot be affected by this problem, are shown in white color. Very light image areas are shown in a gray
tone so that they can be easily distinguished from unprinted areas.
How to check for and adjust minimum dot problems
1. Open a CMYK (plus spot) image in Adobe Photoshop.
2. Click File > Automate > MinDot Preview or select MinDot Preview in the plugin panel.
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3. Set the range you want to check (in the example all below 3% Cyan) and click OK.

All problematic areas below (and including) 3% Cyan are highlighted in Cyan color.
(To see whether the MinDot Preview is currently active or not, just check the image title for the
"GMG_MinDot" suffix.)

4. Click File > Automate > MinDot Adjust or select MinDot Adjust in the plugin panel.
5. Decide whether to remove all color values below the threshold or to set a specific minimum dot
value.
If you set a specific value, you have the additional option to keep the paper tint or equally set it to
the defined threshold value.
In our example, we remove Cyan below 3%.
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6. Click OK.
The minimum dot of Cyan has been adjusted.

7. Deactivate the minimum dot preview again by clicking the OFF button in the plugin panel.

Minimum dot handling options
Available options

Description

Remove

Deletes all pixels below the defined threshold.

Set with Clipping

Sets all color values below the defined threshold to the threshold value, i. e. if the threshold
is set to 3%, all values below 3% are set to 3%. Color values above the threshold are not
touched. This might result in a visible edge.

Set with Curve

Transfers all color values below the defined threshold to the printable tone value range while
keeping details in the gradients. To avoid a visible edge and to keep details, a curve is applied
to the clipped values and to the color values slightly above the threshold.

Preserve 0% Tone Value

Only available for Set with Clipping and Set with Curve. Unprinted areas, i. e. image areas
with tone values of 0.0%, are unchanged. If this option is deselected, unprinted areas will be
filled with pixels set to the threshold value.
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3.6 OpenColor Preview
Note Requires a GMG OpenColor license and a direct connection to the application, please see "Preferences" on page 11
OpenColor Preview allows you to soft proof multicolor image data (CMYK plus spot), and can be used in a
similar way as the Adobe Photoshop feature Proof Colors. The soft proof profile is calculated on-the-fly by
GMG OpenColor .
In GMG OpenColor, you will need a project characterizing the output colors / target color space. You will
then need to publish the separation profiles to make the project available to the GMG ColorPlugin. You
may, but you do not need to, precalculate ChannelChanger profiles in GMG OpenColor. You also do not
need to export the profiles. GMG ColorPlugin connects to GMG OpenColor and requests the needed profiles on-the-fly.
How to use OpenColor Preview
Note You will need a GMG OpenColor project with published separation profiles.
1. Open a CMYK or multichannel image in Adobe Photoshop.
2. Click File > Automate > OpenColor Preview or click OpenColor Preview in the plugin panel.
3. Select the GMG OpenColor project defining the target color space.
4. Map the image channels to the output inks used in the project.

Fig. 9 OpenColor Preview settings.
Identical ink names are automatically mapped. In the example, Black was manually mapped to Pantone
469 C.

3.7 How Can I Apply My Own Profiles?
There are two ways of applying your own profiles created in GMG ProfileEditor or GMG OpenColor:
l

Simply browse for a single profile (ColorConversion > Load Custom Profile).

l

Add your profiles to the profile library to be permanently available in the Destination Space list.
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Required Profile Format: MX4 / MX4x Profiles
Depending on the operating system you are running Photoshop on, you may need to update existing MX4
profiles to another file format: MX4x.

When using Photoshop on a Mac system, you need MX4x profiles. When using Photoshop on a Windows system, you can apply
MX4 profiles AND MX4x profiles.
If you have MX4 profiles, these need to be updated to *.mx4x
first.
Profile Library Path: /UserProfile Library Path:
s/Public/GMG/PhotoshopPlugin/Profiles
/Library/Application Support/GMG/Profiles

Note Updating the profile format is only supported with GMG ProfileEditor in GMG ColorServer 4.10.
How to update MX4 profiles for use on a Mac system
1. Open an MX4 profile in GMG ProfileEditor.
2. Profile Type: Check to ensure the profile type CMYK Conversion Profile is selected.
3. Under Embed ICC Profile, click the + button and select the ICC profile that matches the destination
color space (Output Intent ICC profile).

4. If you do not have a matching ICC profile, you can easily create one by clicking Import/Export >
Export CMYK Output Intent ICC.
(Check to ensure the selected gamut is valid and available for the computer you are working on).
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5. File menu > Save As: Save the profile as *.mx4x profile by manually adding the file extension to the
file name.

6. Close the profile.
7. Reopen the profile.
(Closing and reopening the profile is technically necessary to embed the input ICC profile.)
8. Under Embed ICC Profile, click the browse button and select the ICC profile that matches the source
color space (Input ICC profile).

Optional: Enter a short description for the Intent (what that profile does apart from the conversion
from input to output color space, e.g. "TAC300” or a version number).
9. File menu > Save the profile.
10. Copy the updated profile to the respective application file folder
(default path: /Library/Application Support/GMG/Profiles).
All copied profiles will be available in the profile list in GMG ColorPlugin after a restart of Adobe
Photoshop.
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4. Troubleshooting
4.1 License Error
This article describes how you can continue your work if the plugin informs you that the license is invalid.

How to continue work and request a new license
Following this procedure, you will be able to continue your work immediately.
1. Click OK to close the message box.
The application will display the Invalid License message box.
2. Please fill in the form. GMG needs this information for internal documentation.
3. Click Reactivate License.
The license will be reactivated immediately so that you can continue your work. (You will not receive an
e-mail notification.) In some cases, GMG or a local dealer might contact you for further questions.
Note If you are not able to establish an internet connection, you can request a license in offline mode.
However, in this case it can take up to two working days until you get a new license.
Advanced Info Why does a license get invalid?—The software license is bound to the hardware configuration of your specific computer. If you happen to change anything to the hardware after the license
request, for example, replace the network card or add RAM, the license will be invalidated. You are certain that nothing was changed?—In rare cases, a system error can also lead to an invalid license. In any
case, you can reactivate the license immediately and continue your work.
See also:
l

"Licensing the Plugin without Internet Connection" on page 4

l

"Starting and Licensing the Plugin" on page 3
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