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1. Integrate GMGColorServer into Kodak Prinergy
Would you like to simplify your processes and also save time? Integrate GMG ColorServer into your exist-
ing Kodak Prinergy workflow.

In this tutorial, you learn how to easily integrate GMG ColorServer into a Kodak Prinergy workflow with
the help of Rules Based Automation, short RBA. It will guide you through the configuration of your net-
work, GMG ColorServer, and Prinergy as well as showing you how to use the solution.

Rules Based Automation allows for individually customized workflows and can be modified for your indi-
vidual needs. This solution is just one example of how GMG ColorServer can be integrated into a Prinergy
workflow. Please adjust this solution to your needs.

This workflow integration is still based on creating hotfolders at the GMG ColorServer 5. An API integ-
ration is currently not available.

Note Even if the following solution was well tested, the use of RBA is out of scope of GMG products and
services and GMG provides no warranties for the use of this solution.
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2. Technical requirements

Workflow solution:

l Provider: Kodak

l Software: Prinergy

l Supported version: Version 4 to 8

l Additionally license option required: Prinergy RBA license

GMG solution:

l Provider:GMG GmbH & Co. KG

l Software:GMG ColorServer

l Supported version: 5.0 or higher

l Additionally license option required: none
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3. Preparing the network
Creating folders on the Prinergy server

First of all, you need to create GMG ColorServer hotfolders and output folders on the Prinergy server.

These hotfolders and output folders should be placed on the Prinergy Jobs volume in a GMG directory.

Tip Placing the hotfolders and output folders on the Prinergy server guarantees that Prinergy is able to
access these hotfolders for file exchange.

Creating folders on the GMG PC

We recommend placing the hotfolders and output folders on the Prinergy server.

However, if you want to place them on the GMG PC instead of the Prinergy server nevertheless, you have
to make these folders accessible for the Prinergy server as follows:

1. On the GMG workstation, create a new Windows user named Araxi and provide administrator rights
to this user.

Araxi is the default administrator name used by Prinergy. Use the same password that is defined for
the Araxi user in Prinergy.

Tip You do not have to log in to the GMG computer as the Araxi user. This new user is only neces-
sary to enable the access for Prinergy.

2. On the GMG computer, create a share to the network directory that contains the GMG hotfolders and
GMG output folders.

3. On the Prinergy server, open the Prinergy Administrator.

4. From the Tools menu, select Configure System.

5. In the Configuration Options dialog box, click the Input Volumes tab.

6. Click Browse, browse to the shared folder, select it, and click OK.

7. Click Add Volume.

8. Click OK.

Please, consult the Prinergy System Administrator Guides, chapters Creating an Araxi service account
and Setting up a tertiary server, for further information.

Note The following instructions are based on the assumption that the folders have been created on the
Prinergy server and therefore require adjustment.
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4. GMG ColorServer configuration
Adding the hotfolder location

First, you need to add the Prinergy server with your input and output folders to the known locations in
GMG ColorServer.

1. Start the GMG Hotfolder Service Configurator.

2. Add your Prinergy server under Resources > Hotfolder Locations > New.

Fig. 1 Screenshot of adding the Prinergy server as hotfolder location to GMG ColorServer
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5. GMG ColorServer configuration
Creating a PDF hotfolder

The following steps show you how to create a new PDF hotfolder in GMG ColorServer:

1. Start the GMG ColorServer client.

2. Under Hotfolders > PDF hotfolder > New, create a new PDF hotfolder.

After that, a new dialog will open.

Fig. 2 Screenshot of creating a new PDF hotfolder in GMG ColorServer.
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6. GMG ColorServer configuration
Configuring the Host and Input Folders

The following steps show you how to configure the Host and Input Folders section of the dialog window as
follows:

1. Under Host > Target Computer, select your Prinergy server.

2. Under Input Folders > Hotfolder Location, add the hotfolder that is located on your Prinergy server.

3. Under Input Folders, select the option Use Same Folder Structure in Output.

4. Under Input Folders > Folder Depth, select Unlimited

Fig. 3 Screenshot of the Input Folders section after the configuration.
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7. GMG ColorServer configuration
Configuring the Hotfolder Output

Under Workflow, configure the Hotfolder Output section of the dialog window as follows:

1. Under Output > Hotfolder Output, add the output folder that is located on the Prinergy server.

2. Under Output > Hotfolder Output > Existing Files, choose the option Overwrite Existing File.

Note Please, do not add a Prefix or Suffix value under Output Name. Otherwise, the rule set will not be
able to detect the converted files.

Fig. 4 Screenshot of the Hotfolder Output section after the configuration.
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8. GMG ColorServer configuration
Configuring the Cleanup / Backup

Configure the Cleanup / Backup section of the dialog window as follows:

1. Under Cleanup / Backup > Successful Jobs, select Delete Input Files and Delete Job from Job List.

2. Under Cleanup / Backup > Jobs with Warnings, select Delete Input Files and Delete Job from Job
List.

3. Under Cleanup / Backup > Jobs with Warnings, deactivate Move Input Files after Processing.

4. Under Cleanup / Backup > Jobs with Errors, select Delete Input Files.
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9. GMG ColorServer configuration
Configuring the Report

Under Workflow, configure the Report section of the dialog window as follows:

1. Select the Create Report checkbox

2. Under Target Folder, select the same folder that was selected as output folder under Workflow > Out-
put > Hotfolder Output > File Output.

Note Report and PDF output file must be placed in the same folder.

3. Under File Name, select Keep.

4. Under Create Report on, select Always.

5. Under Format, select XML.

6. Disable the Delete Reports After checkbox.

7. Select Overwrite Existing File.

Note Please, do not add a Prefix or Suffix value under Output Name. Otherwise, the rule set will not be
able to detect the converted files.

Fig. 5 Screenshot of the Report section after the configuration.
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10. GMG ColorServer configuration
Finishing the hotfolder configuration

1. Configure all other hotfolder settings according to your needs.

2. Click Save and Close to save the hotfolder settings.

Tip Repeat all these steps for every hotfolder you want to use.
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11. Kodak Prinergy configuration
Setting up the Custom Fields

The following steps show you how to set up the Custom Fields in Prinergy's Custom Fields Manger.

1. Start the Prinergy Workshop and log on with your user ID and password.

2. From the Tools menu, choose Custom Fields Manager.

3. In the Custom Fields Manager dialog box, in the panel on the left side, select Page

4. Click the Add button.

5. In the Add Custom Field dialog box, type GMG-Status into the Name field.

Note Please, use exactly the name GMG-Status and take care of spelling errors. Otherwise, the rule
set will not work.

6. In the Type field, select Text.

7. In the Show in Workshop field, select the checkbox and click Close.

Fig. 6 Screenshot of setting up the Custom Fields in Custom Fields Manager.
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12. Kodak Prinergy configuration
Setting up a trapping template

The following steps show you how to set up a trapping template in Prinergy.

1. From the Tools menu, choose Process Template Editor.

2. From the File menu, choose New Process Template.

3. In the new Process Template, select the Trap checkbox.

4. Expand the Trap option and set up your preferred trapping option.

5. [Optional:] If you want to use thumbnails, select the Thumbnail checkbox.

6. Save the template.

Note Do not select additional checkboxes. Especially the ColorConvert checkbox must not be selec-
ted.

Fig. 7 Screenshot of setting up a trapping template in Process Template Editor.
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13. Kodak Prinergy configuration
Setting up rule sets

This workflow solution uses one copy of a rule set for each hotfolder.

If you use, for example, three hotfolders in GMG InkOptimizer, you need three copies of this rule set.

Note Make sure that you have a copy for each of your hotfolders.
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14. Kodak Prinergy configuration
Importing a rule set

The following steps show you how to import the rule set:

1. Extract the GMG Ruleset ColorServer 5 v01.zip file that you have received together with this
manual.

2. In Job Finder, from the Tools menu, select Rule Set Manager.

Note If you do not have full administrator user rights, (Read Only) is shown in the title bar of the Rule
Set Manager window, and all Rule Set Manager buttons are unavailable.
If you have full administrator rights, all Rule Set Manager buttons will be available.

3. In Rule Set Manager, in the Rule Set Library list, right-click on the root level Rule Sets folder and cre-
ate a new group called GMG.

4. Right-click on GMG and select Import.

5. In the Import dialog box, select the GMG Ruleset ColorServer 5 v01.xml file that you extracted from
the GMG Ruleset ColorServer 5 v01.zip file in Step 1. (see "Extract the GMG Ruleset ColorServer 5
v01.zip file that you have received together with this manual." on page 16).
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15. Kodak Prinergy configuration
Changing a rule set - Rule Set Editor

The first part for changing the rule set will take place in the Rule Set Editor:

1. To open the Rule Set Editor window, double-click the imported rule set.

2. Double-click the connecting line between the Selected pages result and the GMG-Conversion – con-
figure me action.

The Code Editor window opens.

Fig. 8 Screenshot of the Rule Set Editor window.

Changing a rule set - Code Editor

The second part for changing the rule set will take place in the Code Editor:

1. In the Code Editor > line 23, replace the magenta colored text enclosed by quotation marks with the
Hotfolder Name of the hotfolder that you want to use. This should be a short text that describes the
hotfolder settings.

2. In the Code Editor > line 24, replace the magenta colored text enclosed by quotation marks with the
path of the hotfolder that you want to use.

3. In the Code Editor > line 25, replace the magenta colored text enclosed by quotation marks with the
path of the output folder that you want to use.

4. In the Code Editor > line 35, replace the magenta colored text enclosed by quotation marks with the
thickness of the thumbnail border in pixels that you want to use.

5. In the Code Editor > line 47, you can change the magenta colored number with the time out (in
seconds) that you want to use.

Tip The default time out of 900 seconds (15 minutes) turned out to be a good average value, but you
can increase this if you are going to convert very many files at once.

6. Click Save to close the Code Editor.

The Rule Set Editor will show again.

Fig. 9 Screenshot of the Code Editor window after editing.

If you don't want to use trapping after color management
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In the Rule Set Editor, just delete the lower part of the rule, the Page Custom Field Changed event plus all
connected actions.

If you do want to use trapping after color management

If you want to use trapping after color management, the following steps show you what to do:

1. In the Rule Set Editor, double-click the connecting line between Selected result for page is successful
and the refine after color management - configure me action.

The Process Template Path box opens.

2. In the Process Template Path box, enter the trapping template you created earlier and click OK.

The Process Template Path box closes.

Fig. 10 Screenshot of the Rule Parameters Editor and its Process Template Path box.

If you also want to modify the thickness of the Thumbnail border after the refinement

If you want to modify the thickness of the Thumbnail border after the refinement, the following steps show
you what to do:

1. In the Rule Set Editor, double-click Modify Thumbnail.

2. Double-click on both filters and modify the Thumbnail border.

Fig. 11 Screenshot of modifying the Thumbnail border in Rule Set Editor.
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16. Kodak Prinergy configuration
Saving a rule set

The following steps show you how to save the rule set:

1. Save the rule set under the same name that you used as Hotfolder Name earlier, under (see "GMG
ColorServer configuration" on page 7).

2. Close the Rule Set Editor.

3. Create additional copies of the rule set for each GMG Hotfolder.

Note As this workflow solution uses one copy of a rule set for each hotfolder, make sure that you have a
copy for each of your hotfolders.
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17. Using theworkflow solution
Using the rule set

The following steps show you how to use the rule set in your workflow solution:

1. Open the Job Manager.

2. From the Tools menu, select the Rule Set Manager.

3. In the Rule Set Manager, enable all rule sets of the GMG group as system rules.

4. Open or create a job in Prinergy and add some pages.

5. From the View menu, select Visible Columns.

6. Select GMG-Status and click OK.

7. In the Pages view, select all pages that you want to convert and right-click to open the context
menu.

8. From the context menu, select Manual Start Rules > System > GMG > [Name of the conversion].

9. If the Start Process box appears, click OK.

Now, the GMG-Status custom field of every page will be updated and the files will be transferred to
GMG ColorServer.

10. After all processing files are converted or the timeout is reached, switch to the History view.

Tip If any errors should have occurred, an error message will show detailed information about these
errors.

11. Switch to the Thumbnail view.

The status of each page is indicated by a colored frame around the thumbnail in Thumbnail view:

l Processing status in List view will show up surrounded by a blue frame.

l Successful status in List view will show up surrounded by a green frame.

l Successful with warning status in List view will show up surrounded by an orange frame.

l Error status in List view will show up surrounded by a red frame.

Note It might be necessary to refresh the view to see the changed thumbnails.
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Fig. 12 Screenshot of chosing the GMG rule set.
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18. Known limitations
Known issues

The following things are known limitations of the solution:

Importing the rule set

When importing the rule set, the following error message is displayed:

Rule Set Custom Fields - refine after color management - configure me-page is successful in rule set
GMG Ruleset ColorServer 5 forms one or more conditional loops.

Fig. 13 Screenshot of the error message while importing the rule set.

Please, ignore this error message.

Prinergy History

In the Prinergy History, the following error messages occur:

Parameter assignment failed; event "FilterAcceptEvent255", action "SetFieldAction", rule name "GMG-Con-
version - configure me"

Parameter assignment exception; message: Object not set to an instance of an object.

Fig. 14 Screenshot of the Prinergy History error message while importing the rule set.

Please, ignore these error messages.
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19. Additional information and resources
Kodak Prinergy manual

You can find the complete manual of Kodak Prinergy System Administrator Guides 8.0 on the Kodak web-
site:

https://workflowhelp.kodak.com/display/PRINSAG80/Prinergy+System+Administration+Guides

https://workflowhelp.kodak.com/display/PRINSAG80/Prinergy+System+Administration+Guides
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